Wednesday, December 14, 2016

Vague Error Message by Bundler

Bundler could not find compatible versions for gem "sass":
  In Gemfile:
    compass-rails (~> 2.0.4) was resolved to 2.0.4, which depends on
      compass (~> 1.0.0) was resolved to 1.0.0, which depends on
        sass (< 3.5, >= 3.3.13)

    sass-rails (~> 4.0.2) was resolved to 4.0.2, which depends on
      sass (~> 3.2.0)

compass gem has an indirect dependency on sass gem version >= 3.3.13 or < 3.5
compass-rails gem has indirect dependency on sass gem version == 3.2

Ideally, the software should state the cause of the problem and the resolution in a easy to understand language. In this case, The sass gem must be the same for sass-rails and compass-rails gems to install successfully.

No comments:

Post a Comment