Thursday, April 10, 2008

rubygems 1.1.0 on CentOS 5

ruby setup.rb
./lib/rubygems/custom_require.rb:27:in `gem_original_require': no such file to load -- rdoc/rdoc (LoadError)
from ./lib/rubygems/custom_require.rb:27:in `require'
from setup.rb:48

Rubygems is retarded, it will puke until you install ruby-rdoc and rdoc to install the rubygems 1.1

yum install ruby-rdoc

Download rubygems
cd rubygems-1.1.0.tgz
tar -xvzf rubygems-1.1.0.tgz
ruby setup.rb

1 comment:

  1. I'm curious if you know how I can update my RPM database (either by creating an RPM or manually) so I know my rubygems version is accurate with rpm -q rubygems.